<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html lang="de"  xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        
        <meta name="copyright" content="gamigo Advertising GmbH, 2017. All rights reserved." />
        <link rel="copyright" title="Copyright" href="/disclaimer/impressum" />  
        <meta name="publisher" content="gamigo Advertising GmbH" />
        
        <meta http-equiv="pragma" content="no-cache" />
        
        <meta name="robots" content="noarchive" />
        <meta name="revisit-after" content="1 day" />
        
        <meta name="keywords" content="gulli,Filesharing,News,Software,Phreaking,GullisWorld,Gulli,Newsletter,deutschsprachig,deutsch,gulli,gully,gulliworld,gullisworld,it-glossar,rss-feed,entertainment,geschichte,mobiletelefone,robotor,funk,board,forum,redirector,nfo" />
<meta property="og:type" content="website" />
<meta property="og:locale" content="de" />
<meta property="og:site_name" content="gulli.com Der IT- und Tech-Kanal" />
<meta property="og:image" content="http://static.gulli.com/layout/images/gullilogo2.png" />
<meta name="thumbnail" content="http://static.gulli.com/layout/images/gullilogo2.png" />
<meta name="description" content="Der DeepCoder-Algorithmus entwickelt selbstständig Programme auf Basis bestehender Codes." />
<meta name="DC.Description" content="Der DeepCoder-Algorithmus entwickelt selbstständig Programme auf Basis bestehender Codes." />
<meta property="og:url" content="http://www.gulli.com/news/28171-deepcoder-ki-programmiert-indem-code-von-anderen-programmen-geklaut-wird-2017-02-23" />
<meta property="og:title" content="DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird - News - gulli.com" />
<meta property="og:description" content="Der DeepCoder-Algorithmus entwickelt selbstständig Programme auf Basis bestehender Codes." />
<meta property="article:published_time" content="2017-02-23T14:19:42+01:00" />
<meta property="article:author" content="News Redaktion" />
<meta name="news_keywords" content="ki, code, künstliche intelligenz, algorithmus, programmieren, deep learning, machine learning" />
<meta name="DC.Subject" content="ki, code, künstliche intelligenz, algorithmus, programmieren, deep learning, machine learning" />            
        <meta name="DC.language" scheme="NISOZ39.50" content="de" />
        <meta name="DC.publisher" content="gamigo Advertising GmbH" />
        <meta name="DC.rights" content="gamigo Advertising GmbH, 2017. All rights reserved." />
            
        <meta name="apple-itunes-app" content="app-id=642364670, app-argument=http://www.gulli.com/iphone">
        <link rel="apple-touch-icon" type="image/x-icon" href="http://static.gulli.com/layout/icons/apple-touch-icon-precomposed.png"/>
        
        <meta name="google-site-verification" content="6LJSHTt8QsZgeXy7lv68XxuL1HJgUz4cYWjWsXMlgZI" />
                
        <title>DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird - News - gulli.com</title>        
        <link rel="alternate" type="application/rss+xml" title="gulli:board RSS Feed" href="http://ticker.gulli.com/rss" />

        <link rel="icon" href="http://static.gulli.com/layout/icons/gulliicon.png" type="image/png" />
        <link rel="shortcut icon" href="http://static.gulli.com/layout/icons/gulli.ico" type="image/ico" />
        
        <link href="http://static.gulli.com/layout/css/portal.css" media="screen" rel="stylesheet" type="text/css" />        
        <link rel="stylesheet" type="text/css" media="screen" href="http://static.gulli.com/layout/css/slimbox2.css" />
        <link rel="stylesheet" type="text/css" media="screen" href="http://static.gulli.com/layout/css/colorbox.css" >
        
        <link rel="stylesheet" type="text/css" media="print" href="http://static.gulli.com/layout/css/portal_print.css" />
        <link rel="stylesheet" type="text/css" href="//static.gulli.com/layout/partner/camao/camaoAdsense.css" />
                
        <script type="text/javascript" src="http://static.gulli.com/layout/js/jquery-1.6.4.min.js"></script>
        <script type="text/javascript" src="http://static.gulli.com/layout/js/jquery.cookie.js"></script>
        <script type="text/javascript" src="http://static.gulli.com/layout/js/date.js"></script>
        <script type="text/javascript" src="http://static.gulli.com/layout/js/jquery.colorbox-min.js"></script>
        <script type="text/javascript" src="http://static.gulli.com/layout/js/slimbox.js"></script>
        <script type="text/javascript" src="http://static.gulli.com/layout/js/jquery.socialshareprivacy.min.js"></script>
        
        <!-- Social Privacy -->
        <script type="text/javascript">
            jQuery(document).ready(function($){
            if($('#socialshareprivacy').length > 0){
                $('#socialshareprivacy').socialSharePrivacy({
                    'cookie_domain' : 'gulli.com',
                    'css_path' : 'http://static.gulli.com/layout/css/socialshareprivacy/socialshareprivacy.css',
                    services: {
                        facebook: {
                            'dummy_img': 'http://static.gulli.com/layout/css/socialshareprivacy/images/dummy_facebook.png'
                        },
                        twitter: {
                            'dummy_img': 'http://static.gulli.com/layout/css/socialshareprivacy/images/dummy_twitter.png'
                        },
                        gplus: {
                            'dummy_img': 'http://static.gulli.com/layout/css/socialshareprivacy/images/dummy_gplus.png'
                        }
                    }
                }); 
            }
            });
        </script>
        
        <script type="text/javascript" src="http://static.gulli.com/media/partner/swfobject.js"></script>
        
        <script type='text/javascript'>
            (function() {
            var useSSL = 'https:' == document.location.protocol;
            var src = (useSSL ? 'https:' : 'http:') +
            '//www.googletagservices.com/tag/js/gpt.js';
            document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
            })();
        </script>
        
        <script type='text/javascript'>
                            googletag.defineSlot('/6632639/gulli_Portal_News_ODS_Mitte_728x90', [728, 90], 'div-gpt-ad-1347004393500-0').addService(googletag.pubads());
                googletag.defineSlot('/6632639/gulli_Portal_News_ODS_Rechts_160x600', [160, 600], 'div-gpt-ad-1347004393500-1').addService(googletag.pubads());
                googletag.defineSlot('/6632639/gulli_Portal_News_ODS_Rechts_300x250', [[300, 250], [300, 500], [300, 600]], 'div-gpt-ad-1347004393500-2').addService(googletag.pubads());
                googletag.defineSlot('/6632639/gulli_Portal_News_UDS_Mitte_300x250', [300, 250], 'div-gpt-ad-1347004393500-3').addService(googletag.pubads());
                googletag.defineSlot('/6632639/gulli_Portal_News_UDS_Rechts_300x250', [300, 250], 'div-gpt-ad-1347004393500-4').addService(googletag.pubads());
                googletag.defineSlot('/6632639/gulli_News_Billboard', [960, 250], 'div-gpt-ad-1355219102055-0').addService(googletag.pubads());
            
            googletag.pubads().enableSyncRendering();
            googletag.pubads().enableSingleRequest();
            googletag.enableServices();
        </script>

        <style type="text/css">
                        </style>

    </head>
    <body>




<div id="_wallpaper"></div><!-- Takeover-Rotation-Div -->

<div id="gulli_outerDiv">
    <div id="gulli_header"><!-- Header Banner -->
<script type='text/javascript' src='//static.criteo.net/js/ld/publishertag.js'></script> 
<script type='text/javascript' src='http://static.intenium.de/common/skins/js/blkablk.js'></script> 

<!-- normal ads -->
<div style="float:right">
<script type='text/javascript'>
<!--//<![CDATA[
   document.MAX_ct0 ='';
   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
   var m3_r = Math.floor(Math.random()*99999999999);
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("zoneid=105577");document.write("&amp;nodis=1");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   
   document.write ("'></scr"+"ipt>");
//]]>--></script>
</div>

<!-- alternate adblock ad -->
<div id='crt-502780' style='width:728px; height:90px;'></div>
<script type='text/javascript'>
   Criteo.DisplayAcceptableAdIfAdblocked(
       {'zoneid' : 502780,
        'containerid' : 'crt-502780'
    });
</script>


</div>
    <div id="gulli_innerDiv">
        <div id="gulli_innerstDiv">
            <!-- Start _mainCell -->
            <div id="_mainCell">

                <!-- Start _header -->
                <div id="_header">

                    <div id="gulli_header_titel">
									<h2 class="headline_top">Der unabh&auml;ngige IT- und Tech-Kanal!</h2>
					<h2 class="subheadline_top">internet.board.entertainment.games.hardware</h2>
				                    </div>

                    <a href="/" name="top"><img src="http://static.gulli.com/layout/images/vB4/gullilogo.png" id="_logo" alt="gulli Logo" /></a>
                                        <div class="_searchBox">
                        <div class="gcse-searchbox-only" data-resultsUrl="http://www.gulli.com/suche" ></div>
                        <!-- gcse:searchbox-only resultsUrl="http://www.gulli.com/suche"></gcse:searchbox-only -->
                    </div>

                    <script type="text/javascript" src="http://www.google.de/coop/cse/brand?form=cse-search-box&amp;lang=de"></script>

                </div>
                <!-- End _header -->

                <!-- start Navigation -->
                <nav role="main">
                    <div id="_navigation">
                                                <ul id='menu'><li id="menu_item_wrapper_74" class="menuItem"><a href="http://www.gulli.com/" id="menu_item_74" class="unselected" title="Home">Home</a>
<div class="_subNavigation"  ><ul id='submenu_74'><li><a href="/">Seit 1998 unabh&auml;ngiger IT- und Tech Kanal, Forum mit über 1 Million registrierter Usern</a></li></ul></div></li><li id="menu_item_wrapper_79" class="menuItem"><a href="http://board.gulli.com" id="menu_item_79" class="unselected" title="Board">Board</a>
<div class="_subNavigation"  ><ul id='submenu_79'><li><a href="/">Seit 1998 unabh&auml;ngiger IT- und Tech Kanal, Forum mit über 1 Million registrierter Usern</a></li></ul></div></li><li id="menu_item_wrapper_8" class="menuItem"><a href="http://www.gulli.com/news" id="menu_item_8" class="_selected" title="News">News</a>
<div class="_subNavigation" style="display:block;z-index:5;" ><ul id='submenu_8'><li id="submenu_8_item_wrapper_301" class="menuItem"><a href="http://www.gulli.com/news/topnews" id="submenu_8_item_301" class="unselected" title="Topnews">Topnews</a>
</li><li id="submenu_8_item_wrapper_300" class="menuItem"><a href="http://www.gulli.com/news/interviews" id="submenu_8_item_300" class="unselected" title="Interviews">Interviews</a>
</li><li id="submenu_8_item_wrapper_299" class="menuItem"><a href="http://www.gulli.com/news/glossen" id="submenu_8_item_299" class="unselected" title="Glossen">Glossen</a>
</li><li id="submenu_8_item_wrapper_304" class="menuItem"><a href="http://www.gulli.com/news/Reportagen" id="submenu_8_item_304" class="unselected" title="Reportagen">Reportagen</a>
</li><li id="submenu_8_item_wrapper_302" class="menuItem"><a href="http://www.gulli.com/news/Kurioses" id="submenu_8_item_302" class="unselected" title="Kurioses">Kurioses</a>
</li><li id="submenu_8_item_wrapper_325" class="menuItem"><a href="http://ticker.gulli.com/rss" id="submenu_8_item_325" class="unselected" title="RSS-Feed">RSS-Feed</a>
</li><li id="submenu_8_item_wrapper_284" class="menuItem"><a target="_blank" href="http://twitter.com/gulli_com" id="submenu_8_item_284" class="unselected" title="Twitter">Twitter</a>
</li><li id="submenu_8_item_wrapper_247" class="menuItem"><a href="http://www.gulli.com/news/newsletter" id="submenu_8_item_247" class="unselected" title="Newsletter">Newsletter</a>
</li></ul></div></li><li id="menu_item_wrapper_317" class="menuItem"><a href="http://newspresso.gulli.com" id="menu_item_317" class="unselected" title="NewsPresso">NewsPresso</a>
<div class="_subNavigation"  ><ul id='submenu_317'><li id="submenu_317_item_wrapper_322" class="menuItem"><a href="http://newspresso.gulli.com/overview" id="submenu_317_item_322" class="unselected" title="Newsübersicht">Newsübersicht</a>
</li><li id="submenu_317_item_wrapper_323" class="menuItem"><a href="http://newspresso.gulli.com/rules" id="submenu_317_item_323" class="unselected" title="Regeln">Regeln</a>
</li><li id="submenu_317_item_wrapper_320" class="menuItem"><a href="http://newspresso.gulli.com/highscore" id="submenu_317_item_320" class="unselected" title="Highscore">Highscore</a>
</li><li id="submenu_317_item_wrapper_326" class="menuItem"><a href="http://newspresso.gulli.com/rss" id="submenu_317_item_326" class="unselected" title="RSS-Feed">RSS-Feed</a>
</li></ul></div></li><li id="menu_item_wrapper_75" class="menuItem"><a href="http://www.gulli.com/internet" id="menu_item_75" class="unselected" title="Internet">Internet</a>
<div class="_subNavigation"  ><ul id='submenu_75'><li id="submenu_75_item_wrapper_192" class="menuItem"><a href="http://www.gulli.com/internet/wissenswertes" id="submenu_75_item_192" class="unselected" title="Wissenswertes">Wissenswertes</a>
</li><li id="submenu_75_item_wrapper_96" class="menuItem"><a href="http://www.gulli.com/internet/filesharing" id="submenu_75_item_96" class="unselected" title="Filesharing">Filesharing</a>
</li><li id="submenu_75_item_wrapper_191" class="menuItem"><a href="http://www.gulli.com/internet/denkanstoss" id="submenu_75_item_191" class="unselected" title="Denkanstösse">Denkanstösse</a>
</li></ul></div></li><li id="menu_item_wrapper_95" class="menuItem"><a href="http://www.gulli.com/security" id="menu_item_95" class="unselected" title="IT-Sicherheit">IT-Sicherheit</a>
<div class="_subNavigation"  ><ul id='submenu_95'><li id="submenu_95_item_wrapper_81" class="menuItem"><a href="http://www.gulli.com/security/it-glossar" id="submenu_95_item_81" class="unselected" title="IT-Lexikon">IT-Lexikon</a>
</li><li id="submenu_95_item_wrapper_257" class="menuItem"><a href="http://www.gulli.com/security/rechtliches" id="submenu_95_item_257" class="unselected" title="Gesetzliche Lage">Gesetzliche Lage</a>
</li><li id="submenu_95_item_wrapper_252" class="menuItem"><a href="http://www.gulli.com/security/cybercrime" id="submenu_95_item_252" class="unselected" title="Cyberkriminalität">Cyberkriminalität</a>
</li><li id="submenu_95_item_wrapper_360" class="menuItem"><a href="http://www.gulli.com/security/defense" id="submenu_95_item_360" class="unselected" title="Abwehrmaßnahmen">Abwehrmaßnahmen</a>
</li><li id="submenu_95_item_wrapper_254" class="menuItem"><a href="http://www.gulli.com/security/it-forensik" id="submenu_95_item_254" class="unselected" title="IT-Forensik">IT-Forensik</a>
</li><li id="submenu_95_item_wrapper_368" class="menuItem"><a href="http://www.gulli.com/security/facebook" id="submenu_95_item_368" class="unselected" title="Privatsphäre bei Facebook">Privatsphäre bei Facebook</a>
</li></ul></div></li><li id="menu_item_wrapper_357" class="menuItem"><a href="http://www.gulli.com/hard-und-software" id="menu_item_357" class="unselected" title="Hard- und Software">Hard- und Software</a>
<div class="_subNavigation"  ><ul id='submenu_357'><li id="submenu_357_item_wrapper_231" class="menuItem"><a href="http://www.gulli.com/hard-und-software/zeitreise" id="submenu_357_item_231" class="unselected" title="Zeitreise - PC und N-books">Zeitreise - PC und N-books</a>
</li><li id="submenu_357_item_wrapper_89" class="menuItem"><a href="http://www.gulli.com/hard-und-software/tools" id="submenu_357_item_89" class="unselected" title="Tools">Tools</a>
</li></ul></div></li><li id="menu_item_wrapper_355" class="menuItem"><a href="http://www.gulli.com/games" id="menu_item_355" class="unselected" title="Games">Games</a>
<div class="_subNavigation"  ><ul id='submenu_355'><li id="submenu_355_item_wrapper_235" class="menuItem"><a href="http://www.gulli.com/games/zeitreise" id="submenu_355_item_235" class="unselected" title="Geschichte, Gegenwart und Zukunft der PC-Spiele">Geschichte, Gegenwart und Zukunft der PC-Spiele</a>
</li><li id="submenu_355_item_wrapper_309" class="menuItem"><a href="http://www.gulli.com/games/browsergames" id="submenu_355_item_309" class="unselected" title="Online-Spiele">Online-Spiele</a>
</li><li id="submenu_355_item_wrapper_327" class="menuItem"><a href="http://board.gulli.com/thread/1598025-gulliwettbewerbe/" id="submenu_355_item_327" class="unselected" title="gulli:Wettbewerbe">gulli:Wettbewerbe</a>
</li><li id="submenu_355_item_wrapper_193" class="menuItem"><a href="http://www.gulli.com/games/gulli-spiele" id="submenu_355_item_193" class="unselected" title="gulli:Spiele">gulli:Spiele</a>
</li></ul></div></li><li id="menu_item_wrapper_356" class="menuItem"><a href="http://www.gulli.com/mobile" id="menu_item_356" class="unselected" title="Mobile">Mobile</a>
<div class="_subNavigation"  ><ul id='submenu_356'><li id="submenu_356_item_wrapper_230" class="menuItem"><a href="http://www.gulli.com/mobile/zeitreise" id="submenu_356_item_230" class="unselected" title="Zeitreise - Mobile Endgeräte">Zeitreise - Mobile Endgeräte</a>
</li></ul></div></li><li id="menu_item_wrapper_306" class="menuItem"><a href="http://ansichtssache.gulli.com/" id="menu_item_306" class="unselected" title="Ansichtssache">Ansichtssache</a>
<div class="_subNavigation"  ><ul id='submenu_306'><li id="submenu_306_item_wrapper_307" class="menuItem"><a href="http://ansichtssache.gulli.com/" id="submenu_306_item_307" class="unselected" title="Kommentiere und bewerte die Fundstücke.">Kommentiere und bewerte die Fundstücke.</a>
</li></ul></div></li><li id="menu_item_wrapper_371" class="menuItem"><a target="_blank" href="http://apps.gulli.com" id="menu_item_371" class="unselected" title="Apps">Apps</a>
<div class="_subNavigation"  ><ul id='submenu_371'><li><a href="/">Seit 1998 unabh&auml;ngiger IT- und Tech Kanal, Forum mit über 1 Million registrierter Usern</a></li></ul></div></li></ul>                        <div class="Clear"></div>
                    </div>
                </nav>
                <!-- end Navigation -->

                                <div xmlns:v="http://rdf.data-vocabulary.org/#" class="_breadCrumb">
                    <ul>
                        <li><span typeof='v:Breadcrumb'><a rel='v:url' property='v:title' href="http://www.gulli.com/">Gulli.com</a></span></li><li><span typeof='v:Breadcrumb'><a rel='v:url' property='v:title' href="http://www.gulli.com/news">News</a></span></li><li>DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird</li>                    </ul>
                </div>

                

<div style="margin:auto auto 1em auto;text-align:center;"></div>

<!-- start _contentLeft -->
<div id="_contentLeft">

        <script type="text/javascript">
        <!--//<![CDATA[ 
         
        //]]>-->
    </script>

    
    
    	
	
            
    
    
            
    
    

        <div class="_newsCrumb">
                    <div class="FloatL"><img src="http://static.gulli.com/layout/images/redesign/pfeil_l_bc.png" alt="" /> <a title="Sieben erdähnliche Planeten entdeckt, die Leben beherbergen könnten" href="http://www.gulli.com/news/28170-sieben-erdaehnliche-planeten-entdeckt-die-leben-beherbergen-koennten-2017-02-23">vorherige News</a></div>
                        <div class="Clear"></div>
        </div>

                
                <h1 class="Clear">DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird</h1>


                                <div class="Clear"></div>

                            <div class="_imgBoxFloatL">
                <img src="http://static.gulli.com/media/2017/02/thumbs/370/2302deepcoder.jpg" alt="DeepCoder könnte Programmierern das Arbeiten deutlich erleichtern (Foto: Dino Latoga)." />
                <p>DeepCoder könnte Programmierern das Arbeiten deutlich erleichtern (Foto: Dino Latoga).</p>
            </div>
                <h2 class="newsTeaser">Microsoft und die Universität Cambridge haben einen Deep-Learning-Algorithmus entwickelt, der selbstständig einfache Programmcodes schreiben kann. DeepCoder heißt der Algorithmus und hat bereits grundlegende Herausforderungen von Programmier-Wettbewerben gemeistert. Er soll schlussendlich Menschen dabei helfen Programme zu schreiben, ohne dass selbst Programmierkenntnisse vorhanden sind.</h2>
                <span class="news_content"><p>Der Grundgedanke hinter <a href="https://openreview.net/pdf?id=ByldLrqlx" target="_blank">DeepCoder</a> ist, dass Menschen dem <a href="http://www.gulli.com/news/tags/p/tag/algorithmus" target="_blank">Algorithmus</a> eine Idee f&uuml;r ein Programm beschreiben und der Algorithmus selbstst&auml;ndig ein Programm entwickelt, das den Anforderungen entspricht, erkl&auml;rt Marc Brockschmidt vom Microsoft Research Team in Cambridge. Um das zu erreichen, nutzt DeepCoder die sogenannte &ldquo;Program Synthesis&rdquo;-Methode. Dabei werden neue <a href="http://www.gulli.com/news/tags/p/tag/programm" target="_blank">Programme</a> auf Grundlage existierender Codes aus bereits bestehenden Anwendungen geschaffen. DeepCoder testet daf&uuml;r Programmzeilen, durchst&ouml;bert Datenbanken und schaut auf In- und Output, um daraufhin zu klassifizieren, f&uuml;r welche Zwecke die Programmzeilen verwendet werden k&ouml;nnen.</p>
<h3>Mit jeder Anfrage verbessert sich der Algorithmus</h3>
<p>Inzwischen ist die Entwicklung von DeepCoder soweit fortgeschritten, dass der Algorithmus innerhalb von Sekunden komplett funktionale Programme ausspucken kann. Der Machine-Learning-Aspekt sorgt dabei daf&uuml;r, dass Fehler nicht wiederholt und Erkenntnisse akkumuliert werden. In der Folge wird DeepCoder mit jeder Anfrage ein St&uuml;ck besser und schneller.</p>
<p>&ldquo;Das Potenzial f&uuml;r Automatisierung, die diese Art von Technologie erm&ouml;glicht, k&ouml;nnte den Aufwand beim Programmieren deutlich reduzieren&rdquo;, erkl&auml;rt Armando Solar-Lezama vom Massachusetts Institute of Technology (MIT). Zwar ist DeepCoder aktuell nur in der Lage, Programmieraufgaben zu l&ouml;sen, die maximal f&uuml;nf Zeilen <a href="http://www.gulli.com/news/tags/p/tag/code" target="_blank">Code</a> umfassen, Solar-Lezama meint jedoch, dass der Schritt zu komplexen Programmen mit abertausenden Zeilen Code nicht sonderlich gro&szlig; sei. &ldquo;Ein gro&szlig;es St&uuml;ck Code auf einmal rauszuhauen, ist schwer und potenziell unrealistisch&rdquo;, so der MIT-Mitarbeiter. &ldquo;Allerdings werden umfangreiche Programme auch nur dadurch erstellt, dass kleinere Code-Fragmente zusammengef&uuml;hrt werden.&rdquo;/nf</p>
<script>document.write('<a target="_self" href="http://rover.ebay.com/rover/1/707-53477-19255-0/1?icep_ff3=1&pub=5575242005&toolid=10001&campid=5337987819&customid=&ipn=psmain&icep_vectorid=229487&kwid=902099&mtid=824&kw=lg">Die besten Angebote bei ebay finden!</a><img style="text-decoration:none;border:0;padding:0;margin:0;" src="http://rover.ebay.com/roverimp/1/707-53477-19255-0/1?ff3=1&pub=5575242005&toolid=10001&campid=5337987819&customid=&mpt='+Math.floor(Math.random()*999999999)+'">');</script><noscript><a target="_self" href="http://rover.ebay.com/rover/1/707-53477-19255-0/1?icep_ff3=1&pub=5575242005&toolid=10001&campid=5337987819&customid=&ipn=psmain&icep_vectorid=229487&kwid=902099&mtid=824&kw=lg">Die besten Angebote bei ebay finden!</a><img style="text-decoration:none;border:0;padding:0;margin:0;" src="http://rover.ebay.com/roverimp/1/707-53477-19255-0/1?ff3=1&pub=5575242005&toolid=10001&campid=5337987819&customid=&mpt=[CACHEBUSTER]"></noscript></span>

                                                    
                                    <p class="_redakteur Right P0">Bild-Quellen: 
                                <a target="_blank" href="https://www.flickr.com/photos/iamshinji/3063220244/in/photolist-5EFNE9-aMGgrr-aMG3Pe-aMG81x-aMGbXa-an5Vin-ec78kF-aMGjae-aMFV3r-5jcXAb-6qAfy-aMG5S4-oDgMw9-aMFUd8-aMFVS4-9JnCEg-qQR4FS-bydrS-YKa6z-aMG2DF-9gVqfG-oLCXMW-aMFYG4-aMFZqT-aMG7ec-biCKMx-aMG5gz-gLC1qE-aMG3gM-5qFgYC-atc4qb-aMG1Pe-aMG9j4-vW8fo-4CubE2-aMGeGi-aMG14t-7iBogZ-9v2ZLW-dDd7NF-m6tpTa-aMG4vk-aMFQTV-7NFTF6-aMG9XZ-aMFKY8-aMFNaD-aMGdRB-aMFP1x-5WvBYq" title="" rel="nofollow">Flickr/Dino Latoga</a>
                            </p>
            
<!--
                        -->

                        <p class="_redakteur">
                <a href="http://board.gulli.com/member/22248-gullinews">News Redaktion</a> 
                                                                am Donnerstag, 23.02.2017 14:19 Uhr                                
            </p>

                                    <p class="_tags">Tags:
                                    <a href="http://www.gulli.com/news/tags/p/tag/ki">ki</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/code">code</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/k%C3%BCnstliche+intelligenz">künstliche intelligenz</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/algorithmus">algorithmus</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/programmieren">programmieren</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/deep+learning">deep learning</a>
                                    <a href="http://www.gulli.com/news/tags/p/tag/machine+learning">machine learning</a>
                    
            </p>
                         
                                    
            <div class="_bookmark"><div id="socialshareprivacy"></div></div>            
                                    
            
                        <div class="_forumBox">
                <div> Reaktionen zu dieser Nachricht</div>
                                <p class="Right MT12">
                    <strong>
                        <a href="http://board.gulli.com/showthread.php?t=1788514"><img src="http://static.gulli.com/layout/images/redesign/pfeil_r_bc.png" alt="" /> weitere Kommentare lesen</a>
                    </strong>&nbsp;&nbsp;&nbsp;
                    <strong>
                        <a href="http://board.gulli.com/showthread.php?t=1788514?goto=newpost"><img src="http://static.gulli.com/layout/images/redesign/pfeil_r_bc.png" alt="" /> Nachricht kommentieren</a>
                    </strong>
                </p>
            </div>

            <div id="nointelliTXT">
                <!-- <div class="_forumBox">
                    <div>&nbsp;</div>
                </div> -->

                	<!-- <div style="float:left;margin:0 0 2em 0;">
                   		<!-- Gulli.com_300x250_MediumRectangle_3 
				<div id='div-gpt-ad-1417084467159-0' style='width:300px; height:250px;'>
					<script type='text/javascript'>googletag.display('div-gpt-ad-1417084467159-0');</script>
				</div>

                	</div> --> 
                    <div class="_forumBox">
                        <div>Weitere interessante News</div>
                    </div>
                <div id="plista_widget_belowArticle"></div>
            </div>
            <script type="text/javascript">
                document.write('\u003cscript src="' + document.location.protocol + '//static.plista.com/gulli.com_v1.js">\u003c/script>');
            </script>
                <script type="text/javascript">
                        PLISTA.items.push({
                        objectid: '28171',
                        created_at: '1487855982',
                        title: 'DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird',
                        text: 'Microsoft und die Universität Cambridge haben einen Deep-Learning-Algorithmus entwickelt, der selbstständig einfache Programmcodes schreiben kann. DeepCoder heißt der Algorithmus und hat bereits grundlegende Herausforderungen von Programmier-Wettbewerben gemeistert. Er soll schlussendlich Menschen dabei helfen Programme zu schreiben, ohne dass selbst Programmierkenntnisse vorhanden sind.',
                        url: 'http://www.gulli.com/news/28171-deepcoder-ki-programmiert-indem-code-von-anderen-programmen-geklaut-wird-2017-02-23',
                        img: 'http://static.gulli.com/media/2017/02/thumbs/2302deepcoder.jpg'
                    });
                
                    PLISTA.partner.init();

            </script>        
            
            <script type="text/javascript">
                /* <![CDATA[ */
                    window.onload = function() {
                        FlattrLoader.render({
                            'url': 'http://www.gulli.com/news/28171-deepcoder-ki-programmiert-indem-code-von-anderen-programmen-geklaut-wird-2017-02-23',
                            'uid': '23220',
                            'title': 'DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird',
                            'description': 'Microsoft und die Universität Cambridge haben einen Deep-Learning-Algorithmus entwickelt, der selbstständig einfache Programmcodes schreiben kann. DeepCoder heißt der Algorithmus und hat bereits grundlegende Herausforderungen von Programmier-Wettbewerben gemeistert. Er soll schlussendlich Menschen dabei helfen Programme zu schreiben, ohne dass selbst Programmierkenntnisse vorhanden sind.',
                            'category': 'text',
                            'language': 'de_DE',
                            //'tags': '',
                            'button': 'compact',
                            }, 
                            'testtarget', 
                            'replace');
                        };
                /* ]]> */
            </script>    
            
<script type="text/javascript" src="https://apis.google.com/js/plusone.js">
  {lang: 'de'}
</script>
    
    


    	
        
    


</div>
<!-- end _contentLeft -->

<!-- start _contentRight -->
<div id="_contentRight">
	<div style="margin:auto auto 1em auto;">
            
            <!-- ContentAd rechte Spalte 1 -->
<script type='text/javascript'>
<!--//<![CDATA[
   document.MAX_ct0 ='';
   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
   var m3_r = Math.floor(Math.random()*99999999999);
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("zoneid=105579");document.write("&amp;nodis=1");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   
   document.write ("'></scr"+"ipt>");
//]]>--></script>

<!-- alternative script -->
<div id='crt-502783' style='width:300px; height:250px;'></div>
<script type='text/javascript'>
   Criteo.DisplayAcceptableAdIfAdblocked(
       {'zoneid' : 502783,
        'containerid' : 'crt-502783'
    });
</script>

<!-- ContentAd rechte Spalte 1 --> <script type='text/javascript'> <!--//<![CDATA[    document.MAX_ct0 ='';    var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');    var m3_r = Math.floor(Math.random()*99999999999);    document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);    document.write ("zoneid=105579");document.write("&amp;nodis=1");    document.write ('&amp;cb=' + m3_r);    if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);    document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));    document.write ("&amp;loc=" + escape(window.location).substring(0,1600));    if (document.context) document.write ("&context=" + escape(document.context));    if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {        document.write ("&amp;ct0=" + escape(document.MAX_ct0));    }    if (document.mmm_fo) document.write ("&amp;mmm_fo=1");        document.write ("'></scr"+"ipt>"); //]]>--></script>  <!-- alternative script --> <div id='crt-502783' style='width:300px; height:250px;'></div> <script type='text/javascript'>    Criteo.DisplayAcceptableAdIfAdblocked(        {'zoneid' : 502783,         'containerid' : 'crt-502783'     }); </script>
            
	</div>
	
	
	<div class="_infoBox"><div class="headLine">Fotostrecke</div><div class="_gallery"><div><a href="http://static.gulli.com/media/2017/02/2302deepcoder.jpg" rel="lightbox-news"><img alt="DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird" title="DeepCoder: KI programmiert, indem Code von anderen Programmen geklaut wird" src="http://static.gulli.com/media/2017/02/thumbs/2302deepcoder.jpg" /></a></div></div><div class="Clear"></div></div>
	
	<div class="_infoBox"><div class="headLine">News [<a href="http://www.gulli.com/news/kurioses">Kurioses</a>]</div><div><h2><a href="http://www.gulli.com/news/27847-milliardaerssohn-kauft-sieben-iphones-fuer-seinen-hund-2016-09-21" title="Milliardärssohn kauft sieben iPhones für seinen Hund">Milliardärssohn kauft sieben iPhones für seinen Hund</a></h2><p class="_redakteur"><a href="http://board.gulli.com/member/22248-gullinews">News Redaktion</a> am 21.09.2016, 09:04 Uhr</p><a href="http://www.gulli.com/news/27847-milliardaerssohn-kauft-sieben-iphones-fuer-seinen-hund-2016-09-21"><img src="http://static.gulli.com/media/2016/09/thumbs/iphone.jpg" alt="Da kann der Hund aber viel telefonieren: Milliardärssohn kauft Hund sieben iPhones." title="Da kann der Hund aber viel telefonieren: Milliardärssohn kauft Hund sieben iPhones." /></a><p>So tickt die Welt eben: Einige Menschen haben so viel Geld, dass sie nicht wissen, was sie damit tun sollen, andere müssen darum bangen, sich etwas zu Essen leisten zu können. Der Sohn eines chinesischen Milliardärs beispielsweise kaufte für seinen Hund gleich sieben iPhones.</p><p class="readMore Clear Right M0"><a href="http://www.gulli.com/news/27847-milliardaerssohn-kauft-sieben-iphones-fuer-seinen-hund-2016-09-21">mehr lesen...</a></p></div></div>
	<script type="text/javascript" src="http://hal9000.redintelligence.net/zone/mkqrwdw77ytm"></script>
	
	
	
	
	<div style="margin:auto auto 1em auto;"><!-- ContentAd rechte Spalte 2 -->
<script type='text/javascript'>
<!--//<![CDATA[
   document.MAX_ct0 ='';
   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
   var m3_r = Math.floor(Math.random()*99999999999);
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("zoneid=353310");document.write("&amp;nodis=1");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   
   document.write ("'></scr"+"ipt>");
//]]>--></script>





<!-- check ad block -->
<script>
function adBlockNotDetected() {
	//alert('AdBlock is not enabled');
}
// Function called if AdBlock is detected
function adBlockDetected() {
	//alert('AdBlock is enabled');
	$("#crt-502780").css({ "width" : "728px", "height" : "90px" });
        $("#crt-502782").css({ "width" : "300px", "height" : "600px" });
        $("#crt-502783").css({ "width" : "300px", "height" : "250px" });
}

// Recommended audit because AdBlock lock the file 'blkablk.js' (original: blockadblock.js)
// If the file is not called, the variable does not exist 'blockAdBlock'
// This means that AdBlock is present
if(typeof blockAdBlock === 'undefined') {
	adBlockDetected();
} else {
	blockAdBlock.onDetected(adBlockDetected);
	blockAdBlock.onNotDetected(adBlockNotDetected);
	/*
	// and|or
	blockAdBlock.on(true, adBlockDetected);
	blockAdBlock.on(false, adBlockNotDetected);
	// and|or
	blockAdBlock.on(true, adBlockDetected).onNotDetected(adBlockNotDetected);
	*/
}
</script><!-- ContentAd rechte Spalte 2 --> <script type='text/javascript'> <!--//<![CDATA[    document.MAX_ct0 ='';    var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');    var m3_r = Math.floor(Math.random()*99999999999);    document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);    document.write ("zoneid=353310");document.write("&amp;nodis=1");    document.write ('&amp;cb=' + m3_r);    if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);    document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));    document.write ("&amp;loc=" + escape(window.location).substring(0,1600));    if (document.context) document.write ("&context=" + escape(document.context));    if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {        document.write ("&amp;ct0=" + escape(document.MAX_ct0));    }    if (document.mmm_fo) document.write ("&amp;mmm_fo=1");        document.write ("'></scr"+"ipt>"); //]]>--></script>      <!-- check ad block --> <script> function adBlockNotDetected() { 	//alert('AdBlock is not enabled'); } // Function called if AdBlock is detected function adBlockDetected() { 	//alert('AdBlock is enabled'); 	$("#crt-502780").css({ "width" : "728px", "height" : "90px" });         $("#crt-502782").css({ "width" : "300px", "height" : "600px" });         $("#crt-502783").css({ "width" : "300px", "height" : "250px" }); }  // Recommended audit because AdBlock lock the file 'blkablk.js' (original: blockadblock.js) // If the file is not called, the variable does not exist 'blockAdBlock' // This means that AdBlock is present if(typeof blockAdBlock === 'undefined') { 	adBlockDetected(); } else { 	blockAdBlock.onDetected(adBlockDetected); 	blockAdBlock.onNotDetected(adBlockNotDetected); 	/* 	// and|or 	blockAdBlock.on(true, adBlockDetected); 	blockAdBlock.on(false, adBlockNotDetected); 	// and|or 	blockAdBlock.on(true, adBlockDetected).onNotDetected(adBlockNotDetected); 	*/ } </script></div>
	
	
	
	
	
</div>
<!-- end _contentRight --> 

                <div class="infoIcons"><a href="http://www.gullipics.com/" target="_blank"><img title="gulli:pics" alt="gulli:pics" src="http://static.gulli.com/layout/images/vB4/gpics.png" /></a><a href="http://www.gulli.com/tipafriend"><img title="Artikel empfehlen" alt="Artikel empfehlen" src="http://static.gulli.com/layout/images/vB4/seiteempfehl.png" /></a><a href="http://ticker.gulli.com/rss/"><img src="http://static.gulli.com/layout/images/vB4/rss.png" title="gulli RSS News Feeds" alt="gulli RSS News Feeds" /></a><a href="http://newspresso.gulli.com/rss"><img src="http://static.gulli.com/layout/images/vB4/rss_newspresso.png" title="gulli RSS NewsPresso Feeds" alt="gulli RSS NewsPresso Feeds" /></a><a href="http://www.gulli.com/news/newsletter"><img title="gulli:Newsletter" alt="gulli:Newsletter" src="http://static.gulli.com/layout/images/vB4/newsletter.png" /></a><a href="http://twitter.com/gulli_com" target="_blank"><img title="gulli twittert" alt="gulli twittert" src="http://static.gulli.com/layout/images/vB4/twitter.png" /></a><a href="http://www.facebook.com/#!/pages/gulli/14708300300" target="_blank"><img title="gulli bei facebook" alt="gulli bei facebook" src="http://static.gulli.com/layout/images/vB4/fratzenbook.png" /></a><a href="//plus.google.com/108047376957049650571?prsrc=3" target="_blank"><img src="//static.gulli.com/layout/icons/service/google_plus.png" alt="Google+" title="Google+" /></a><a href="http://itunes.apple.com/de/app/gulli-news/id356168603?mt=8" target="_blank"><img title="gulli:news im AppStore" alt="gulli:news im AppStore" src="http://static.gulli.com/layout/images/vB4/app.png" /></a></div>
                <div id="_contentFooter"><ul><li><a href="http://www.gulli.com/home">Home</a></li><li><a href="http://www.gulli.com/news">News</a></li><li><a href="http://newspresso.gulli.com">NewsPresso</a></li><li><a href="http://www.gulli.com/internet">Internet</a></li><li><a href="http://www.gulli.com/security">IT-Sicherheit</a></li><li><a href="http://www.gulli.com/hard-und-software">Hard- und Software</a></li><li><a href="http://www.gulli.com/games">Games</a></li><li><a href="http://www.gulli.com/mobile">Mobile</a></li><li><a href="http://www.gulli.com/disclaimer/werbung">Werbung</a></li><li><a href="http://www.gulli.com/presse">Presse</a></li><li><a href="http://www.gulli.com/kontakt">Kontakt</a></li><li><a href="http://www.gulli.com/disclaimer">Impressum / Datenschutz</a></li><li><a href="http://www.gulli.com/chat">Chat</a></li><li><a href="https://de.gamigo.com/unternehmen/karriere-jobs/">Jobs</a></li><li><a href="http://www.gulli.com/Suche">Suche</a></li></ul><br class="Clear" /><p>&copy; 1998-2017 gamigo Advertising GmbH</p><a href="http://www.hardwareclips.com/" target="_blank"><img src="http://static.gulli.com/layout/icons/hwclips_logo.jpg" alt="Hardwareclips" /></a></div>
            </div>
            <!-- end MainCell-->
        </div>
    </div>
    <div id="gulli_sky"><!-- Skyscrapper rechts 1 -->
<script type='text/javascript'>
<!--//<![CDATA[
   document.MAX_ct0 ='';
   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
   var m3_r = Math.floor(Math.random()*99999999999);
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("zoneid=105574");document.write("&amp;nodis=1");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   
   document.write ("'></scr"+"ipt>");
//]]>--></script>


<!-- alternative script -->
<div id='crt-502782' style='width:300px; height:600px;'></div>
<script type='text/javascript'>
   Criteo.DisplayAcceptableAdIfAdblocked(
       {'zoneid' : 502782,
        'containerid' : 'crt-502782'
    });
</script>

</div>
</div>

    
    <!-- start Vibrant Media IntelliTXT script section -->
    <script type="text/javascript" src="http://gulli.de.intellitxt.com/intellitxt/front.asp?ipid=54797"></script>
    <!-- end Vibrant Media IntelliTXT script section -->

    <!-- Begin comScore Tag --> 
    <script> 
        var _comscore = _comscore || []; 
        _comscore.push({ c1: "2", c2: "10011458" }); 
        (function() { 
            var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; 
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el); 
        })(); 
    </script> 
    <noscript> 
        <img src="http://b.scorecardresearch.com/p?c1=2&c2=10011458&cv=2.0&cj=1" /> 
    </noscript>

    <script type="text/javascript">

      var _gaq = _gaq || [];
      _gaq.push(['_setAccount', 'UA-222090-2']);
      _gaq.push (['_gat._anonymizeIp']);
      _gaq.push(['_trackPageview']);

      (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
      })();

    </script>

    <script>
      (function() {
        var cx = 'partner-pub-9251202204878699:2557475796';
        var gcse = document.createElement('script'); gcse.type = 'text/javascript'; gcse.async = true;
        var src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
            '//www.google.de/cse/cse.js?cx=' + cx;
        //var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(gcse, s);
        document.write('<scr' + 'ipt  type="text/javascript" async=true src="' + src + '"></scr' + 'ipt>');
      })();
    </script>

<script type="text/javascript" src="http://as.ebz.io/api/choixPubJS.htm?pid=308411&screenLayer=1&mode=NONE&home=http://www.gulli.com"></script>




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5J45WG"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5J45WG');</script>
<!-- End Google Tag Manager -->



<script src="//js.smartredirect.de/js/?h=HR8N4p9S" type="text/javascript" async></script>
    </body>
</html>
